Как установить признак модифицированности формы (1cv82)

Материал из КинтВики
Версия от 15:36, 7 июля 2016; Дмитрий Малюгин (обсуждение | вклад)

(разн.) ← Предыдущая | Текущая версия (разн.) | Следующая → (разн.)
Перейти к: навигация, поиск


При прямой программном изменении данных флаг модифицированности формы НЕ УСТАНАВЛИВАЕТСЯ.


Для того чтобы система нормально отрабатывала событие "ПриЗакрытии", т.е. задавала вопрос "Сохранить/отменить", нужно установить флаг модификации формы:

<source lang=1c> ЭтаФорма.Модифицированность = Истина; </source>

Например:

<source lang=1c> &НаКлиенте Процедура ДобавитьКомментарий() стрВведенныйКомментарий = ""; Если НЕ ВвестиСтроку(стрВведенныйКомментарий, "Комментарий", 0, Истина) Тогда Возврат; КонецЕсли; Если стрВведенныйКомментарий = "" Тогда Возврат КонецЕсли;

строка = Объект.Комментарии.Добавить(); строка.Автор = Мета.ТекущийПользователь(); строка.Дата = ТекущаяДата(); строка.Комментарий = стрВведенныйКомментарий;

Элементы.ТаблицаКомментариев.ТекущаяСтрока = Объект.Комментарии.Количество() - 1; ЭтаФорма.Модифицированность = Истина; КонецПроцедуры

</source>