Как установить признак модифицированности формы (1cv82) — различия между версиями

Материал из КинтВики
Перейти к: навигация, поиск
(Новая страница: «Категория:Программирование в 1Cv82 {{notice|При прямой программном изменении данных флаг мод...»)
 
м
 
Строка 1: Строка 1:
[[Категория:Программирование в 1Cv82]]
+
[[Категория: Формы 1Cv8]]
  
 
{{notice|При прямой программном изменении данных флаг модифицированности формы НЕ УСТАНАВЛИВАЕТСЯ.}}
 
{{notice|При прямой программном изменении данных флаг модифицированности формы НЕ УСТАНАВЛИВАЕТСЯ.}}

Текущая версия на 15:36, 7 июля 2016


При прямой программном изменении данных флаг модифицированности формы НЕ УСТАНАВЛИВАЕТСЯ.


Для того чтобы система нормально отрабатывала событие "ПриЗакрытии", т.е. задавала вопрос "Сохранить/отменить", нужно установить флаг модификации формы:

<source lang=1c> ЭтаФорма.Модифицированность = Истина; </source>

Например:

<source lang=1c> &НаКлиенте Процедура ДобавитьКомментарий() стрВведенныйКомментарий = ""; Если НЕ ВвестиСтроку(стрВведенныйКомментарий, "Комментарий", 0, Истина) Тогда Возврат; КонецЕсли; Если стрВведенныйКомментарий = "" Тогда Возврат КонецЕсли;

строка = Объект.Комментарии.Добавить(); строка.Автор = Мета.ТекущийПользователь(); строка.Дата = ТекущаяДата(); строка.Комментарий = стрВведенныйКомментарий;

Элементы.ТаблицаКомментариев.ТекущаяСтрока = Объект.Комментарии.Количество() - 1; ЭтаФорма.Модифицированность = Истина; КонецПроцедуры

</source>