Особенности работы с отчетами (1Cv8)

Материал из КинтВики
Перейти к: навигация, поиск


Программное формирование отчета, использование расшифровки

<source lang=1C> // Процедура вызывается при выборе пункта подменю "Сформировать" меню "Действия" // командной панели ДействияФормы. // Процедура Сформировать() ДанныеРасшифровки = Неопределено; ЭлементыФормы.Результат.Очистить(); КомпоновщикНастроек.Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Период", НаДату); СкомпоноватьРезультат(ЭлементыФормы.Результат, ДанныеРасшифровки); КонецПроцедуры // Сформировать()


// Процедура - обработчик события "Действие" элемента ДействияФормы.ВыборВарианта. // Процедура ДействияФормыВыборВарианта(Кнопка) макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"); спВарианты = Новый СписокЗначений; Для каждого вариант из макет.ВариантыНастроек Цикл спВарианты.Добавить(вариант.Настройки, вариант.Представление); КонецЦикла;

выбор = спВарианты.ВыбратьЭлемент(); Если выбор = Неопределено Тогда Возврат; КонецЕсли;

КомпоновщикНастроек.ЗагрузитьНастройки(выбор.Значение);

Сформировать(); КонецПроцедуры // ДействияФормыВыборВарианта()


</source>

Если не передать в "СкомпоноватьРезультат" параметр "ДанныеРасшифровки", то в таблице расшифровка не работает!.